routerOS port forwarding.

rudy

[H]F Junkie
Joined
Apr 4, 2004
Messages
8,704
lol so I don't know whats wrong with me but I have been trying to get port forwarding working on routerOS and I cant do it. I want to run a Halflife server, I can run the server and people can connect through the LAN but no one can see it from the valve master servers outside the network. Like I had to tell you the symptoms right?

Has anyone used this router and know if there is something I am missing. Because it is very much more powerful than a home router it has a ton of options and maybe I am just totally missing something that is obvious to networking people but not obvious to someone used to home user routers.
 
Port forwarding is easy, just do a NAT rule:

Code:
/ip firewall nat add chain=dstnat action=dst-nat to-addresses=<lan ip> protocol=tcp dst-port=27015 log=no

Same for UDP:

Code:
/ip firewall nat add chain=dstnat action=dst-nat to-addresses=<lan ip> protocol=udp dst-port=27015 log=no


That's enough for the router. To make your server appear on public list you have to add this to the bottom of your server.cfg:

Code:
setmaster add 193.84.64.9:27010 
setmaster add 69.28.151.162 
setmaster add 72.165.61.189 
setmaster add 207.173.177.11
setmaster add 65.73.232.251:27040
setmaster add 65.73.232.253:27040
setmaster add 207.173.177.12:27010



Hope this helps.
 
Back
Top